summaryrefslogtreecommitdiffstats
path: root/tdeio/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
commit5159cd2beb2e87806a5b54e9991b7895285c9d3e (patch)
tree9b70e8be47a390f8f4d56ead812ab0c9dad88709 /tdeio/CMakeLists.txt
parentc17cb900dcf52b8bd6dc300d4f103392900ec2b4 (diff)
downloadtdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.tar.gz
tdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeio/CMakeLists.txt')
-rw-r--r--tdeio/CMakeLists.txt71
1 files changed, 71 insertions, 0 deletions
diff --git a/tdeio/CMakeLists.txt b/tdeio/CMakeLists.txt
new file mode 100644
index 000000000..826fbf743
--- /dev/null
+++ b/tdeio/CMakeLists.txt
@@ -0,0 +1,71 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_definitions(
+ -D_LARGEFILE64_SOURCE=1
+)
+
+add_subdirectory( kssl )
+add_subdirectory( tdeio )
+add_subdirectory( bookmarks )
+add_subdirectory( tdefile )
+add_subdirectory( pics )
+add_subdirectory( tdeioexec )
+add_subdirectory( httpfilter )
+add_subdirectory( misc )
+add_subdirectory( kpasswdserver )
+add_subdirectory( tests )
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${LIBR_LIBDIR}
+)
+
+
+##### other data ################################
+
+install( FILES magic DESTINATION ${MIME_INSTALL_DIR} )
+
+install( FILES
+ application.desktop kurifilterplugin.desktop
+ kcomprfilter.desktop kscan.desktop kdatatool.desktop
+ tdefileplugin.desktop tdecmodule.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+
+install( FILES tdeioslave.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
+install( PROGRAMS useragent.pl proxytype.pl DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
+install( FILES renamedlgplugin.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+install( FILES kpasswdserver.desktop DESTINATION ${SERVICES_INSTALL_DIR}/kded )
+install( FILES data.protocol DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+if( HAVE_ELFICON )
+ set( ELFICON_STATIC_LIB tdelficon-static )
+endif( HAVE_ELFICON )
+
+
+##### libtdeio ####################################
+
+set( target tdeio )
+
+configure_file( ${CMAKE_SOURCE_DIR}/cmake/modules/template_dummy_cpp.cmake dummy.cpp COPYONLY )
+
+tde_add_library( ${target} SHARED
+ SOURCES ${CMAKE_CURRENT_BINARY_DIR}/dummy.cpp
+ VERSION 4.2.0
+ EMBED kssl-static tdeiocore-static tdesycoca-static kbookmarks-static tdefile-static ${ELFICON_STATIC_LIB}
+ LINK ltdlc-static tdeui-shared tdesu-shared tdewalletclient-shared ${LIBR_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
+)