summaryrefslogtreecommitdiffstats
path: root/tdeio/httpfilter/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
commit5159cd2beb2e87806a5b54e9991b7895285c9d3e (patch)
tree9b70e8be47a390f8f4d56ead812ab0c9dad88709 /tdeio/httpfilter/CMakeLists.txt
parentc17cb900dcf52b8bd6dc300d4f103392900ec2b4 (diff)
downloadtdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.tar.gz
tdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeio/httpfilter/CMakeLists.txt')
-rw-r--r--tdeio/httpfilter/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/tdeio/httpfilter/CMakeLists.txt b/tdeio/httpfilter/CMakeLists.txt
new file mode 100644
index 000000000..b40f10fdc
--- /dev/null
+++ b/tdeio/httpfilter/CMakeLists.txt
@@ -0,0 +1,32 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdeio
+)
+
+
+##### httpfilter ################################
+
+set( target httpfilter )
+
+set( ${target}_SRCS
+ httpfilter.cc
+)
+
+tde_add_library( ${target} STATIC_PIC AUTOMOC
+ SOURCES ${${target}_SRCS}
+)