summaryrefslogtreecommitdiffstats
path: root/tdeio/kssl/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-27 01:04:16 -0600
commit5159cd2beb2e87806a5b54e9991b7895285c9d3e (patch)
tree9b70e8be47a390f8f4d56ead812ab0c9dad88709 /tdeio/kssl/Makefile.am
parentc17cb900dcf52b8bd6dc300d4f103392900ec2b4 (diff)
downloadtdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.tar.gz
tdelibs-5159cd2beb2e87806a5b54e9991b7895285c9d3e.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeio/kssl/Makefile.am')
-rw-r--r--tdeio/kssl/Makefile.am72
1 files changed, 72 insertions, 0 deletions
diff --git a/tdeio/kssl/Makefile.am b/tdeio/kssl/Makefile.am
new file mode 100644
index 000000000..5d57ab7ab
--- /dev/null
+++ b/tdeio/kssl/Makefile.am
@@ -0,0 +1,72 @@
+# don't change the order of this one. it breaks when openssl is in /usr/include
+# and the distro's KDE is there too, but the current "devel" KDE prefix is
+# somewhere else. Another option for the future (needs testing) would be to
+# change SSL_INCLUDES to .../include/openssl and make the source use #include <foo.h>
+# instead of #include <openssl/foo.h>
+INCLUDES=-I$(top_srcdir)/tdecore/network -I$(top_srcdir)/tdewallet/client $(all_includes) $(SSL_INCLUDES)
+
+noinst_LTLIBRARIES = libkssl.la
+KSSLVERSION= 3.0.0
+KSSLPATCH= 0
+METASOURCES= AUTO
+
+include_HEADERS = \
+ kssl.h \
+ ksslcertificatehome.h \
+ ksslsettings.h \
+ ksslcertificate.h \
+ ksslconnectioninfo.h \
+ ksslcertificatefactory.h \
+ ksslcertificatecache.h \
+ ksslpeerinfo.h \
+ ksslinfodlg.h \
+ ksslcertdlg.h \
+ ksslutils.h \
+ kopenssl.h \
+ ksslall.h \
+ ksslpkcs12.h \
+ ksslcertchain.h \
+ ksslkeygen.h \
+ ksslx509v3.h \
+ ksslsigners.h \
+ ksslpkcs7.h \
+ ksslpemcallback.h \
+ ksslconfig.h \
+ ksslsession.h \
+ ksslx509map.h \
+ ksmimecrypto.h
+
+noinst_HEADERS = ksslcsessioncache.h
+
+
+libkssl_la_SOURCES = \
+ kssl.cc \
+ ksslcertificatehome.cc \
+ ksslsettings.cc \
+ ksslcertificate.cc \
+ ksslconnectioninfo.cc \
+ ksslcertificatefactory.cc \
+ ksslcertificatecache.cc \
+ ksslpeerinfo.cc \
+ ksslinfodlg.cc \
+ ksslcertdlg.cc \
+ ksslutils.cc \
+ kopenssl.cc \
+ ksslpkcs12.cc \
+ ksslcertchain.cc \
+ ksslkeygen.cc \
+ ksslx509v3.cc \
+ ksslsigners.cc \
+ ksslpkcs7.cc \
+ ksslpemcallback.cc \
+ ksslx509map.cc \
+ ksslsession.cc \
+ keygenwizard.ui \
+ keygenwizard2.ui \
+ ksmimecrypto.cc \
+ ksslcsessioncache.cc
+
+
+SUBDIRS = kssl
+
+include $(top_srcdir)/admin/Doxyfile.am