summaryrefslogtreecommitdiffstats
path: root/tdeprint/lpd/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
commite16866e072f94410321d70daedbcb855ea878cac (patch)
treeee3f52eabde7da1a0e6ca845fb9c2813cf1558cf /tdeprint/lpd/Makefile.am
parenta58c20c1a7593631a1b50213c805507ebc16adaf (diff)
downloadtdelibs-e16866e072f94410321d70daedbcb855ea878cac.tar.gz
tdelibs-e16866e072f94410321d70daedbcb855ea878cac.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'tdeprint/lpd/Makefile.am')
-rw-r--r--tdeprint/lpd/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/tdeprint/lpd/Makefile.am b/tdeprint/lpd/Makefile.am
new file mode 100644
index 000000000..5c6559a27
--- /dev/null
+++ b/tdeprint/lpd/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES= -I$(top_srcdir) -I$(top_srcdir)/tdeprint -I$(top_srcdir)/tdeprint/management $(all_includes)
+
+kde_module_LTLIBRARIES = tdeprint_lpd.la
+
+tdeprint_lpd_la_SOURCES = kmlpdfactory.cpp kmlpdmanager.cpp klpdprinterimpl.cpp kmlpduimanager.cpp \
+ lpdtools.cpp gschecker.cpp
+tdeprint_lpd_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+tdeprint_lpd_la_LIBADD = $(top_builddir)/tdeprint/management/libtdeprint_management.la
+tdeprint_lpd_la_METASOURCES = AUTO
+
+noinst_HEADERS = kmlpdfactory.h kmlpdmanager.h klpdprinterimpl.h kmlpduimanager.h lpdtools.h gschecker.h
+
+bin_PROGRAMS = make_driver_db_lpd
+make_driver_db_lpd_SOURCES = make_driver_db_lpd.c
+make_driver_db_lpd_LDADD = $(top_builddir)/tdecore/libtdefakes.la
+
+entry_DATA = lpd.print
+entrydir = $(kde_datadir)/tdeprint/plugins