summaryrefslogtreecommitdiffstats
path: root/tdeprint/rlpr/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-11-06 15:56:40 -0600
commite16866e072f94410321d70daedbcb855ea878cac (patch)
treeee3f52eabde7da1a0e6ca845fb9c2813cf1558cf /tdeprint/rlpr/Makefile.am
parenta58c20c1a7593631a1b50213c805507ebc16adaf (diff)
downloadtdelibs-e16866e072f94410321d70daedbcb855ea878cac.tar.gz
tdelibs-e16866e072f94410321d70daedbcb855ea878cac.zip
Actually move the kde files that were renamed in the last commit
Diffstat (limited to 'tdeprint/rlpr/Makefile.am')
-rw-r--r--tdeprint/rlpr/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/tdeprint/rlpr/Makefile.am b/tdeprint/rlpr/Makefile.am
new file mode 100644
index 000000000..1946fed94
--- /dev/null
+++ b/tdeprint/rlpr/Makefile.am
@@ -0,0 +1,17 @@
+AM_CPPFLAGS = -D_KDEPRINT_COMPILE
+
+INCLUDES= -I$(top_srcdir) -I$(top_srcdir)/tdeprint -I$(top_srcdir)/tdeprint/management $(all_includes)
+
+kde_module_LTLIBRARIES = tdeprint_rlpr.la
+
+tdeprint_rlpr_la_SOURCES = kmrlprfactory.cpp kmrlprmanager.cpp krlprprinterimpl.cpp kmrlpruimanager.cpp \
+ kmwrlpr.cpp kmproprlpr.cpp kmproxywidget.cpp kmconfigproxy.cpp
+tdeprint_rlpr_la_LDFLAGS = $(all_libraries) -module -avoid-version -no-undefined
+tdeprint_rlpr_la_LIBADD = $(top_builddir)/tdeprint/management/libtdeprint_management.la $(LIB_QT) $(LIB_KDEPRINT) $(LIB_KDECORE) $(LIB_KDEUI)
+tdeprint_rlpr_la_METASOURCES = AUTO
+
+noinst_HEADERS = kmrlprmanager.h krlprprinterimpl.h kmrlpruimanager.h kmwrlpr.h kmproprlpr.h \
+ kmproxywidget.h kmconfigproxy.h
+
+entry_DATA = rlpr.print
+entrydir = $(kde_datadir)/tdeprint/plugins