summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 794c2afbd..c9ae8384c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1225,14 +1225,26 @@ if ( NOT ISPELL_LIBDIR )
endif ( NOT ISPELL_LIBDIR )
##### check for aspell ##########################
-# we need ASPELL_DATADIR too
if( WITH_ASPELL )
find_package( ASPELL )
if( NOT ASPELL_FOUND )
message(FATAL_ERROR "\nASPELL support are requested, but not found on your system" )
endif( NOT ASPELL_FOUND )
+ if( NOT ASPELL_DATADIR )
+ find_program( PSPELL_CONFIG_EXECUTABLE NAMES pspell-config DOC "path to the pspell-config executable" )
+ if( PSPELL_CONFIG_EXECUTABLE )
+ execute_process (
+ COMMAND ${PSPELL_CONFIG_EXECUTABLE} --pkgdatadir
+ OUTPUT_VARIABLE ASPELL_DATADIR
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
+ endif( PSPELL_CONFIG_EXECUTABLE )
+ endif( NOT ASPELL_DATADIR )
endif( WITH_ASPELL )
+if( NOT ASPELL_DATADIR )
+ set ( ASPELL_DATADIR "/usr/lib/aspell" )
+endif( NOT ASPELL_DATADIR )
+set ( ASPELL_DATADIR "${ASPELL_DATADIR}" CACHE PATH "aspell data directory" )
##### check for hspell ##########################