summaryrefslogtreecommitdiffstats
path: root/dcop/dcopidl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'dcop/dcopidl/Makefile.am')
-rw-r--r--dcop/dcopidl/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/dcop/dcopidl/Makefile.am b/dcop/dcopidl/Makefile.am
new file mode 100644
index 000000000..2b07f5e0a
--- /dev/null
+++ b/dcop/dcopidl/Makefile.am
@@ -0,0 +1,27 @@
+
+INCLUDES = $(all_includes)
+AM_LDFLAGS = $(all_libraries)
+AM_CPPFLAGS = -DYYDEBUG
+
+####### Files
+
+bin_PROGRAMS = dcopidl
+
+dcopidl_SOURCES = main.cpp yacc.cc scanner.cc
+noinst_HEADERS = yacc.cc.h
+
+dcopidl_LDADD = $(LIB_QT)
+dcopidl_LDFLAGS = $(KDE_RPATH) $(AM_LDFLAGS)
+
+####### Build rules
+
+parser:
+ cd $(srcdir) && flex -B -8 -oscanner.cc scanner.ll ;\
+ bison -t -d -v -o yacc.cc yacc.yy && mv yacc.hh yacc.cc.h
+
+check-local:
+ $(srcdir)/run_test.sh $(srcdir)
+
+EXTRA_DIST = dcopidl_test.h scanner.ll yacc.yy
+
+MAINTAINERCLEANFILES = yacc.cc.output