summaryrefslogtreecommitdiffstats
path: root/dcop/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'dcop/tests/CMakeLists.txt')
-rw-r--r--dcop/tests/CMakeLists.txt21
1 files changed, 7 insertions, 14 deletions
diff --git a/dcop/tests/CMakeLists.txt b/dcop/tests/CMakeLists.txt
index 1eb0c4227..164947e9b 100644
--- a/dcop/tests/CMakeLists.txt
+++ b/dcop/tests/CMakeLists.txt
@@ -30,24 +30,12 @@ tde_add_check_executable( dcop_test AUTOMOC
DEPENDENCIES dcop_tests_generated
)
-set_property(
- SOURCE test.cpp
- APPEND PROPERTY
- OBJECT_DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/test_skel.cpp
-)
-
tde_add_check_executable( driver AUTOMOC
SOURCES driver.cpp ${CMAKE_CURRENT_BINARY_DIR}/test.stub
LINK tdecore-shared
DEPENDENCIES dcop_tests_generated
)
-set_property(
- SOURCE driver.cpp
- APPEND PROPERTY
- OBJECT_DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/test_stub.cpp
-)
-
add_test( NAME "dcop/dcop-tests"
COMMAND sh -x "${CMAKE_CURRENT_SOURCE_DIR}/run-tests.sh"
WORKING_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}" )
@@ -55,9 +43,14 @@ add_test( NAME "dcop/dcop-tests"
set_tests_properties( dcop/dcop-tests PROPERTIES TIMEOUT 30)
-##### test.h and files ##########################
+##### generated files ###########################
-add_custom_target( dcop_tests_generated DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/test.h )
+add_custom_target( dcop_tests_generated
+ DEPENDS
+ ${CMAKE_CURRENT_BINARY_DIR}/test.h
+ ${CMAKE_CURRENT_BINARY_DIR}/test_skel.cpp
+ ${CMAKE_CURRENT_BINARY_DIR}/test_stub.cpp
+)
add_custom_command(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/test.h ${CMAKE_CURRENT_BINARY_DIR}/shell.generated