summaryrefslogtreecommitdiffstats
path: root/kio/misc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kio/misc/Makefile.am')
-rw-r--r--kio/misc/Makefile.am60
1 files changed, 0 insertions, 60 deletions
diff --git a/kio/misc/Makefile.am b/kio/misc/Makefile.am
deleted file mode 100644
index 0bafce0f5..000000000
--- a/kio/misc/Makefile.am
+++ /dev/null
@@ -1,60 +0,0 @@
-# This file is part of the KDE libraries
-# Copyright (C) 1997 Torben Weis (weis@kde.org)
-
-# This library is free software; you can redistribute it and/or
-# modify it under the terms of the GNU Library General Public
-# License as published by the Free Software Foundation; either
-# version 2 of the License, or (at your option) any later version.
-
-# This library is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# Library General Public License for more details.
-
-# You should have received a copy of the GNU Library General Public License
-# along with this library; see the file COPYING.LIB. If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
-# Boston, MA 02110-1301, USA.
-
-AM_CPPFLAGS = -D_LARGEFILE64_SOURCE
-
-INCLUDES= -I$(srcdir)/.. -I$(top_srcdir) -I$(srcdir)/../kssl -I../kssl $(all_includes) $(SSL_INCLUDES)
-
-SUBDIRS = . ksendbugmail kpac tdesasl kssld kfile tdewalletd tdentlm
-
-lib_LTLIBRARIES =
-tdeinit_LTLIBRARIES = kio_uiserver.la
-bin_PROGRAMS = kmailservice ktelnetservice
-
-observer_DIR = $(top_srcdir)/kio/kio
-
-kio_uiserver_la_SOURCES = uiserver.cpp uiserver.skel observer.stub
-kio_uiserver_la_LIBADD = $(LIB_KIO) $(LIB_TDEUI) $(LIB_QT) $(top_builddir)/dcop/libDCOP.la $(LIB_TDECORE)
-kio_uiserver_la_LDFLAGS = $(all_libraries) -module -avoid-version
-
-METASOURCES = AUTO
-
-kde_services_DATA = kio_uiserver.desktop
-
-kmailservice_SOURCES = kmailservice.cpp
-kmailservice_LDADD = $(LIB_TDECORE)
-kmailservice_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
-
-ktelnetservice_SOURCES = ktelnetservice.cpp
-ktelnetservice_LDADD = $(LIB_TDEUI)
-ktelnetservice_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_KIO) -ltdetexteditor
-
-protocol_DATA = kmailservice.protocol telnet.protocol rlogin.protocol rtsp.protocol ssh.protocol \
- mms.protocol mmst.protocol mmsu.protocol pnm.protocol rtspt.protocol rtspu.protocol
-protocoldir = $(kde_servicesdir)
-
-kiomiscdir = $(includedir)/kio
-kiomisc_HEADERS = uiserver.h
-
-
-bin_SCRIPTS = fileshareset
-install-exec-local:
- @-rm -f $(DESTDIR)$(bindir)/filesharelist
- @$(LN_S) fileshareset $(DESTDIR)$(bindir)/filesharelist
- @(chown root $(DESTDIR)$(bindir)/fileshareset && chmod 4755 $(DESTDIR)$(bindir)/fileshareset) || echo "Was not able to make fileshareset setuid root"
-