summaryrefslogtreecommitdiffstats
path: root/mimetypes/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mimetypes/CMakeLists.txt')
-rw-r--r--mimetypes/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/mimetypes/CMakeLists.txt b/mimetypes/CMakeLists.txt
index 6ecf4836f..da5ad54c3 100644
--- a/mimetypes/CMakeLists.txt
+++ b/mimetypes/CMakeLists.txt
@@ -22,4 +22,10 @@ add_subdirectory( uri )
##### other data ################################
-install( FILES all.desktop allfiles.desktop DESTINATION ${MIME_INSTALL_DIR}/all )
+foreach( _mimetype all.desktop allfiles.desktop )
+ tde_create_translated_desktop(
+ SOURCE ${_mimetype}
+ DESTINATION ${MIME_INSTALL_DIR}/all
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/mimetypes
+ )
+endforeach()