summaryrefslogtreecommitdiffstats
path: root/mimetypes/model/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'mimetypes/model/CMakeLists.txt')
-rw-r--r--mimetypes/model/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/mimetypes/model/CMakeLists.txt b/mimetypes/model/CMakeLists.txt
index b101c70aa..49c21f98b 100644
--- a/mimetypes/model/CMakeLists.txt
+++ b/mimetypes/model/CMakeLists.txt
@@ -11,6 +11,12 @@
##### other data ################################
-install( FILES
+foreach( _mimetype
vrml.desktop
- DESTINATION ${MIME_INSTALL_DIR}/model )
+)
+ tde_create_translated_desktop(
+ SOURCE ${_mimetype}
+ DESTINATION ${MIME_INSTALL_DIR}/model
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/mimetypes
+ )
+endforeach()