summaryrefslogtreecommitdiffstats
path: root/tdespell2/plugins/hspell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tdespell2/plugins/hspell/CMakeLists.txt')
-rw-r--r--tdespell2/plugins/hspell/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/tdespell2/plugins/hspell/CMakeLists.txt b/tdespell2/plugins/hspell/CMakeLists.txt
new file mode 100644
index 000000000..960b54ff4
--- /dev/null
+++ b/tdespell2/plugins/hspell/CMakeLists.txt
@@ -0,0 +1,49 @@
+#################################################
+#
+# (C) 2010 Serghei Amelian
+# serghei (DOT) amelian (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+include_directories(
+ ${TQT_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}/tdecore
+ ${CMAKE_SOURCE_DIR}/tdespell2
+ ${CMAKE_SOURCE_DIR}/tdecore
+ ${HSPELL_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${HSPELL_LIBARY_DIRS}
+)
+
+
+##### other data ################################
+
+install( FILES tdespell_hspell.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
+
+
+#### tdespell_hspell ##############################
+
+### FIXME Not checked because hspell was removed from gentoo few years ago.
+### FIXME The maintainer recommend to use aspell with hebrew dictionary.
+### FIXME Maybe support for hspell will be removed too?
+### FIXME http://bugs.gentoo.org/show_bug.cgi?id=177546
+
+set( target tdespell_hspell )
+
+set( ${target}_SRCS
+ tdespell_hspellclient.cpp tdespell_hspelldict.cpp
+)
+
+tde_add_kpart( ${target} AUTOMOC
+ SOURCES ${${target}_SRCS}
+ LINK tdespell2-shared ${HSPELL_LIBRARIES}
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)