summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/tdeio-apt/debian/fixrpath
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-06 14:38:41 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-03-06 14:38:41 -0600
commite473251d6d5a894f939a57e580e38e9e96b9cd69 (patch)
treed28b7cf287c6fcd65ebdb01573389885e2133ebc /debian/lenny/applications/tdeio-apt/debian/fixrpath
parent309f28e865c2733f3752110254ba8c227b980876 (diff)
downloadtde-packaging-e473251d6d5a894f939a57e580e38e9e96b9cd69.tar.gz
tde-packaging-e473251d6d5a894f939a57e580e38e9e96b9cd69.zip
Update Debian and Ubuntu packaging to match new module names
Diffstat (limited to 'debian/lenny/applications/tdeio-apt/debian/fixrpath')
-rwxr-xr-xdebian/lenny/applications/tdeio-apt/debian/fixrpath25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/lenny/applications/tdeio-apt/debian/fixrpath b/debian/lenny/applications/tdeio-apt/debian/fixrpath
new file mode 100755
index 000000000..0ca44359e
--- /dev/null
+++ b/debian/lenny/applications/tdeio-apt/debian/fixrpath
@@ -0,0 +1,25 @@
+#!/bin/sh
+# $Id: fixrpath,v 1.1 2006/11/19 12:01:24 lpnotfr Exp $
+# libtool -rpath workaround based on a suggestion by Yann Dirson
+# <dirson@debian.org>
+#
+# It is supposed to be inserted in configure.in, but I didn't want
+# to re-run autoconf (since that bloats the Debian diff unnecessarily),
+# so I just patch libtool after running configure. -- Richard Braakman
+# <dark@xs4all.nl>
+#
+# The version of libtool included with LessTif unfortunately insists on
+# linking with -rpath, i.e. hardwiring locations. This is not desirable.
+#
+# The dummy define is improbable enough not to conflict with anything; it is
+# just here to fool libtool by making it believe it gave some useful info to
+# gcc.
+#
+# This will also patch the generated libtool to explicitly
+# link libraries against the libraries they depend on. (particularly libc)
+
+sed < $1/libtool > $1/libtool-2 \
+ -e 's/^hardcode_libdir_flag_spec.*$/hardcode_libdir_flag_spec=" -D__LIBTOOL_IS_A_FOOL__ "/' \
+ -e '/^archive_cmds="/s/"$/ \$deplibs"/'
+mv $1/libtool-2 $1/libtool
+chmod 755 $1/libtool