summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kxmleditor/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-05-09 20:38:28 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-05-09 20:38:28 +0200
commitf2b3fcc64e6fb551fbc5f4cd62f15128697ab08b (patch)
tree4a723a2043cdc34ffb47974d736a7e85963bcfb8 /ubuntu/_base/applications/kxmleditor/debian/rules
parentded8dc0c76e59ed36c14f7a8705aa02b4d33ee0c (diff)
downloadtde-packaging-f2b3fcc64e6fb551fbc5f4cd62f15128697ab08b.tar.gz
tde-packaging-f2b3fcc64e6fb551fbc5f4cd62f15128697ab08b.zip
DEB kxmleditor: Switch to cmake.
Add basic package documentation. The man page has been moved to the main tree. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/applications/kxmleditor/debian/rules')
-rwxr-xr-xubuntu/_base/applications/kxmleditor/debian/rules17
1 files changed, 12 insertions, 5 deletions
diff --git a/ubuntu/_base/applications/kxmleditor/debian/rules b/ubuntu/_base/applications/kxmleditor/debian/rules
index 2aebaac7b..cee2a3058 100755
--- a/ubuntu/_base/applications/kxmleditor/debian/rules
+++ b/ubuntu/_base/applications/kxmleditor/debian/rules
@@ -1,12 +1,19 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"