summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/tdmtheme/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-22 00:20:07 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-01-22 00:20:07 -0600
commit96dbf4dcb1e04571363422a97649fc929b35beb8 (patch)
treead8c3a9d2d4c1e9919a30ec7663e3f0b64e7d8f9 /ubuntu/maverick/applications/tdmtheme/debian/rules
parent80e4199df2ac852cfb22848698cabe9ba28e5a67 (diff)
downloadtde-packaging-96dbf4dcb1e04571363422a97649fc929b35beb8.tar.gz
tde-packaging-96dbf4dcb1e04571363422a97649fc929b35beb8.zip
Second part of prior commit
Diffstat (limited to 'ubuntu/maverick/applications/tdmtheme/debian/rules')
-rwxr-xr-xubuntu/maverick/applications/tdmtheme/debian/rules38
1 files changed, 38 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/tdmtheme/debian/rules b/ubuntu/maverick/applications/tdmtheme/debian/rules
new file mode 100755
index 000000000..0eb4fad95
--- /dev/null
+++ b/ubuntu/maverick/applications/tdmtheme/debian/rules
@@ -0,0 +1,38 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-Wl,--as-needed"
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/kde
+
+post-patches:: debian/stamp-bootstrap
+
+debian/stamp-bootstrap:
+ ! [ -f /usr/share/libtool/ltmain.sh ] || \
+ cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+ ! [ -f /usr/share/libtool/config/ltmain.sh ] || \
+ cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+
+ make -f admin/Makefile.common cvs
+ touch debian/stamp-bootstrap
+
+install/tdmtheme-trinity::
+ install -D -p -m644 debian/tdmtheme.lintian-overrides \
+ debian/tdmtheme-trinity/usr/share/lintian/overrides/tdmtheme-trinity
+
+get-orig-source:
+ @@dh_testdir
+ @@[ -d ../tarballs/. ]||mkdir -p ../tarballs
+ @@dpatch-get-origtargz ../tarballs
+