summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Beier <dontmind@freeshell.org>2015-05-28 16:02:52 +0200
committerChristian Beier <dontmind@freeshell.org>2015-05-28 16:02:52 +0200
commit97f442ef2aa65ade6bea11e90054c57b90abbaca (patch)
tree78361ab8a669da971149644902d190cbef54ad89 /CMakeLists.txt
parent92f558482d94c5152174a1983a40863bd6b07911 (diff)
downloadlibtdevnc-97f442ef2aa65ade6bea11e90054c57b90abbaca.tar.gz
libtdevnc-97f442ef2aa65ade6bea11e90054c57b90abbaca.zip
Instead of letting the build system define endianess, rely on endian.h.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 338f0ba..168873f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,6 @@ project(LibVNCServer)
include(CheckFunctionExists)
include(CheckIncludeFile)
include(CheckTypeSize)
-include(TestBigEndian)
include(CheckCSourceCompiles)
include(CheckCXXSourceCompiles)
include(CheckCSourceRuns)
@@ -163,8 +162,6 @@ if(NOT HAVE_LIBVNCSERVER_IN_ADDR_T)
set(LIBVNCSERVER_NEED_INADDR_T 1)
endif(NOT HAVE_LIBVNCSERVER_IN_ADDR_T)
-TEST_BIG_ENDIAN(LIBVNCSERVER_WORDS_BIGENDIAN)
-
# TODO:
# LIBVNCSERVER_ENOENT_WORKAROUND
# inline