summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Beier <cb@shoutrlabs.com>2016-12-30 18:09:54 +0100
committerChristian Beier <cb@shoutrlabs.com>2016-12-30 18:09:54 +0100
commitac478e6c708941c7f028b4d6a7a7dd0732f53bff (patch)
tree91dddcf3ffaf1b37016958611b8178570b7f515e /CMakeLists.txt
parent16cf35b2bf7b38784b384f1982c7f65bd3fc0142 (diff)
downloadlibtdevnc-ac478e6c708941c7f028b4d6a7a7dd0732f53bff.tar.gz
libtdevnc-ac478e6c708941c7f028b4d6a7a7dd0732f53bff.zip
Fix some OSX linker problems.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b350c4..488b334 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,6 +87,12 @@ if(NOT HAVE_B64_IN_LIBC)
if(HAVE_B64_IN_LIBRESOLV)
set(RESOLV_LIB "resolv")
endif(HAVE_B64_IN_LIBRESOLV)
+
+ # the function check somehow fails for apple but the function is there
+ if(APPLE)
+ set(RESOLV_LIB "resolv")
+ endif(APPLE)
+
endif(NOT HAVE_B64_IN_LIBC)
if(Threads_FOUND)