summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b350c4..488b334 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -87,6 +87,12 @@ if(NOT HAVE_B64_IN_LIBC)
if(HAVE_B64_IN_LIBRESOLV)
set(RESOLV_LIB "resolv")
endif(HAVE_B64_IN_LIBRESOLV)
+
+ # the function check somehow fails for apple but the function is there
+ if(APPLE)
+ set(RESOLV_LIB "resolv")
+ endif(APPLE)
+
endif(NOT HAVE_B64_IN_LIBC)
if(Threads_FOUND)