summaryrefslogtreecommitdiffstats
path: root/tdeprint/ext/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-07 18:25:52 +0200
commit4b7a4e17362206fd2eade35ba947a850263b0ea1 (patch)
tree3f3e619da9fd3c0f76ef95e44c73898a278e059b /tdeprint/ext/CMakeLists.txt
parent31fa399a0aa455f3f52251f977233d57e92de28c (diff)
downloadtdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.tar.gz
tdelibs-4b7a4e17362206fd2eade35ba947a850263b0ea1.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'tdeprint/ext/CMakeLists.txt')
-rw-r--r--tdeprint/ext/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tdeprint/ext/CMakeLists.txt b/tdeprint/ext/CMakeLists.txt
index 83b1e3dab..f974e490a 100644
--- a/tdeprint/ext/CMakeLists.txt
+++ b/tdeprint/ext/CMakeLists.txt
@@ -31,7 +31,11 @@ link_directories(
##### other data ################################
-install( FILES ext.print DESTINATION ${DATA_INSTALL_DIR}/tdeprint/plugins )
+tde_create_translated_desktop(
+ SOURCE ext.print
+ DESTINATION ${DATA_INSTALL_DIR}/tdeprint/plugins
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/tdeprint-desktops
+)
##### tdeprint_ext ##############################