summaryrefslogtreecommitdiffstats
path: root/tdespell2/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-01-26 13:17:21 -0600
commitdfe289850f068f19ba4a83ab4e7e22a7e09c13c9 (patch)
treec297348a55df66c571de4525646e0b9762427353 /tdespell2/Makefile.am
parentb7658a0d5eca24a9d37c6e04f88298ef02389db0 (diff)
downloadtdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.tar.gz
tdelibs-dfe289850f068f19ba4a83ab4e7e22a7e09c13c9.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdespell2/Makefile.am')
-rw-r--r--tdespell2/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/tdespell2/Makefile.am b/tdespell2/Makefile.am
new file mode 100644
index 000000000..00ee8a81d
--- /dev/null
+++ b/tdespell2/Makefile.am
@@ -0,0 +1,24 @@
+SUBDIRS = . ui tests plugins
+METASOURCES = AUTO
+
+noinst_LTLIBRARIES = libtdespell2base.la
+
+AM_CPPFLAGS = -DKDE_NO_COMPAT -DQT_NO_COMPAT -I$(top_srcdir)/tdeutils $(all_includes)
+
+tdespell2baseincludedir = $(includedir)/tdespell2
+
+tdespell2baseinclude_HEADERS = settings.h filter.h \
+ dictionary.h broker.h \
+ backgroundchecker.h defaultdictionary.h
+
+libtdespell2base_la_SOURCES = settings.cpp broker.cpp \
+ client.cpp filter.cpp backgroundchecker.cpp \
+ backgroundthread.cpp backgroundengine.cpp \
+ defaultdictionary.cpp
+
+libtdespell2base_la_LDFLAGS = -no-undefined $(all_libraries)
+
+servicetype_DATA = tdespellclient.desktop
+servicetypedir = $(kde_servicetypesdir)
+
+include $(top_srcdir)/admin/Doxyfile.am